Centralized Nymi Agent Crashes with Nymi WebAPI

After you configure the nymi_agent.toml file and restart the Nymi Agent service, the Nymi Agent service stop.

The nymi_agent.log file reports the following errors:


                Child Smith.Napi.Supervisor of Supervisor Smith.Supervisor failed to start
                ** (exit) an exception was raised:
                ** (CaseClauseError) no case clause matching: {:error, :enoent}
            

Cause

This issue appears because the nymi_agent.toml is configured to use BasicLoginWithToken but one or both of the following steps were not completed:

  • Credentials of the Nymi Infrastructure Service Account account were not encrypted during the Nymi Agent installation.
  • For secure Websockets(wss) the TLS certificates and key are not in the C:\Nymi\NymiAgent\certs folder folder.

Resolution

To resolve this issue, perform the following steps:

  1. From the command prompt change to the C:\Nymi\NymiAgent\Tools directory, and type the following command: cryptoutil.exe encrypt-service-account -i C:\Nymi\NymiAgent\creds.text -o C:\Nymi\NymiAgent\

    The Cryptoutil tool creates the following files in the C:\Nymi\NymiAgent\certs folder:

    • credentials-contains the encrypted credentials for the Nymi Infrastructure Service Account
    • Private key
    • Public key
  2. Permanently delete the C:\Nymi\NymiAgent\creds.txt file.
  3. Place following files in the C:\Nymi\NymiAgent\certs folder.
    • CA root certificate bundle in PEM format
    • Server certificate in PEM format
    • Server certificate private key in PEM format
  4. Restart the Nymi Agent service.

Articles in this section

Was this article helpful?
0 out of 0 found this helpful
Share

Comments

0 comments

Please sign in to leave a comment.