Console Login Fails with "Error during connection with the security services"

Console Login Fails with "Error during connection with the security services"

This issue appears when you attempt to log into the Evidian EAM Management Console.

You will also see the following error information: Network error: the EAM Security Services are unavailable. The Windows Service "EAM Security Services" is probably stopped. Please contact your administrator. Error code: 0x81011005

This message can appear for several reasons

Cause 1

The Evidian EAM Controller does not have connectivity to the Active Directory server.

Resolution 1

  1. Confirm that the Evidian EAM Controller can communicate with the AD server. For example, confirm that you can ping the AD server.
  2. On the AD server, review the properties of the account. Re-enable the account.

Cause 2

The password for the primary administrator account for the Evidian EAM Controller has changed or the account is disabled.

Resolution 2

Perform the following steps to update the password in the Evidian EAM Controller:
  1. Log in with a domain administrator account.
  2. From the EAM installation package navigate to the ..\EAM-v10.X\EAM.x64\TOOLS\WGSRVConfig directory.
  3. Double-click WGSRVConfig.exe.
  4. On the User Account Control window, click Yes.
  5. On the Controller Configuration select, select Configure security settings, as shown the following figure.
    Figure 1. Configure Security Settings option
  6. On the Directory tab, in the Password and Confirmation fields, specify the new password.
  7. Click OK.
  8. Close the EAM Administration Tools window.
  9. Restart the Enterprise Access Management Security Services service.

Cause 3

The Evidian EAM Controller is configured to use LDAPS but the environment uses LDAP.

In this situation, the following errors also appear in the wgss log files:

               AdsiHandler.cpp               :0715:   [PING] : No new server found (0x81010009)
               AdsiHandler.cpp               :0716: CAdsiHandler::Ping returned: 0x81020029
               LdapBaseRequests.cpp          :2761:[PING] Ping for domain O=EAM returned: 0x81020029
               FrameworkServer.cpp           :0202:Wait 5 secs for services to start...
           

Resolution 3

Perform the following steps to configure the Evidian EAM Controller to use LDAP:

  1. Run regedit.exe
  2. Navigate to HKLM\Software\Enatel\Framework\WGDirectory.
  3. Edit the SSL key and change the value from 1 to 0.
  4. Restart the Enterprise Access Management Security Service service.

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