Operation Failed. Please try again later

Operation Failed. Please try again later

This error message appears when you perform a tap to perform an SSO action.

The following image provides an example of the error message.

Figure 1. Operation Failed. Please try again later

Cause

The initialization of the nymi_api.dll and retrieval of authentication token from Nymi AgentNES is taking longer than expected and does not complete within the default time period.

Resolution

To resolve this issue, install the latest supported version of EAM 10.02 PL2 or EAM 10.01.7125.10 and then define the following registry key on each machine that runs the MES application.

  1. Run regedit.exe.
  2. Navigate to HKLM\Software\Enatel\Wiseguard\FrameWork\Authentication\.
  3. Create a new DWORD (32 bit value) registry key named WearableDelay with a value set to more than 2000 ms. Nymi recommends a value of 10000.

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