Nymi Band Tap Not Detected

In a Citrix/RDP session, when a user performs a Nymi Band tap, the Nymi-Enabled Application(NEA) does not detect the tap.

Cause

The user terminal has multiple network adapters and the network connection has switched from one network adapter to another.

In this situation, the nymi_blueooth_endpoint.log files does not report the error Nymi Bluetooth Endpoint is missing and also displays messages that show that the Nymi Bluetooth Endpoint reconnects to the Nymi Agent and the subscribes to a topic with a different IP address.

Resolution

Log out (not just disconnect) of the current Citrix / RDP session, and then relaunch the session, which starts a new application session and triggers Nymi API to start and subscribe to the new IP address.

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