NES Application Pool Stopped

In IIS Manager, the NES Application Pool is in the Stopped state. When you start the application pool, the pool runs for a short time but stops again.

When you attempt to connect to the NES Administrator Console, a 503 error appears.

Cause 1

The password the application pool identity account has expired or changed, or the account is disabled.

Resolution 1

Correct the issue with the account, and if you changed the password, then perform the following steps to update the password in IIS.

  1. In IIS Manager, from the navigation pane, select Application Pools.
  2. Right-click the NES Application Pool, and select Advanced Settings, as shown in the following figure
    Figure 1. Application Pool Advanced Settings option
  3. Click the Ellipses for the Identity setting as shown in the following figure.
    Figure 2. Application Pool Advanced Identity option
  4. On the App Pool Identity window, click Set, as shown in the following figure.
    Figure 3. Application Pool Advanced Identity option
  5. On the Set Credentials window, type the username for the application pool identity, and the new password. Click OK.
    Figure 4. Application Pool Advanced Identity option
  6. In IIS Manager, from the navigation pane, select the server name.
  7. From the Actions menu, click Restart.

Cause 2

Microsoft Monitoring Agent is stopping the application pool.

The following error appears in the Application Event Log file:


                Log Name: Application
                Source: Application Error
                Date: dd/mm/yyyy
                Event ID: 1000
                Task Category: (100)
                Level: Error
                Keywords: Classic
                User: N/A
                Computer: xyz
                Description:
                Faulting application name: w3wp.exe, version: 8.0.9200.16384, time stamp: 0x50108835
                Faulting module name: PerfMon64.dll, version: 8.0.10918.0, time stamp: 0x577fd168
                Exception code: 0xc0000409
                Fault offset: 0x0000000000149794
                Faulting process id: 0x2c38
                Faulting application start time: 0x01d24405d195eb6a
                Faulting application path: c:\windows\system32\inetsrv\w3wp.exe
                Faulting module path: C:\Program Files\Microsoft Monitoring Agent\Agent\APMDOTNETAgent\V8.0.10918.0\PerfMon64.dll
            

Resolution 2

Disable the Microsoft Monitoring APM service or remove the APM component from the application

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