Cannot connect to a Nymi Band. Nymi Bluetooth Endpoint is missing. Start the Nymi Bluetooth Endpoint service or contact your administrator
This error message appears after you log in to the Nymi Band Application.
The following figure shows the error message.
The nem.log file contains the following errors:
NAPI READ: {"operation":"error","exchange":null,"status":5100,"payload":{},"error":{"error_description":"Nymi Bluetooth Endpoint is missing.","error_specifics":""}}
INFO Band service disconnected, error code: 5100
Cause 1
- The Bluetooth adapter is not plugged into the Nymi Band Application Terminal.
- The Nymi Bluetooth Endpoint service is not running or needs to be reset.
Resolution 1
To resolve this issue, perform one of the following actions:
- Plug or reseat the Bluetooth adapter into a free USB port.
- Restart the Nymi Bluetooth Endpoint service.
Cause 2
The Nymi Band Application is installed on a Citrix server or RDP session host, the Nymi Bluetooth Endpoint is installed on the user terminal, but port 9120 was blocked.
Resolution 2
Configure the firewall to allow bidirectional communication over port 9120 between the Nymi Agent on the remote server and the Nymi Bluetooth Endpoint on the user terminal that accesses the remote server.
Cause 3
The Enrollment Terminal is connecting to a centralized Nymi Agent but the nbe.toml file is not configured with the location of the Nymi Agent.
Resolution 3
Navigate to the C:\Nymi\Bluetooth_Endpoint directory. If an nbe.toml file exists, rename the file and then restart the Nymi Bluetooth Endpoint service.
Cause 4
The user is accessing the Nymi Band Application through an RDP connection but the RDP connection host (local user terminal) does not have the Nymi Bluetooth Endpoint service running.
Resolution 4
On the RDP connection host (local user terminal), install the Nymi Bluetooth Endpoint and configure the nbe.toml file to specify the location of the Nymi Agent (Enrollment Terminal).
Cause 5
The Nymi Band Application connects to a centralized Nymi Agent and the load balancer has configured the Nymi Agent servers in Active/Active mode, which is an unsupported configuration. Multiple Nymi Agent services are handling requests for the same Nymi Band Application session.
The nymi_api.log file includes the following error messages:
ERROR - serrec - Received error polling dongle: The device does not recognize the command. (os error 22)
WARN - BGADAPTER: error on dongle reader thread: receiving on an empty and disconnected channel
INFO - BLE Dongle removed.
ERROR - error terminating dongle polling thread: sending on a disconnected channel
INFO - Polling thread joined 2023-04-10 12:58:55.271998700 INFO - Adapter status changed: StateResponse { state: "7" }
INFO - BLE Dongle connected.
Resolution 5
On the load balancer, configure the Nymi Agent servers in Active/Standy mode.
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