This error message appears in the Nymi Band Application during enrollment.
The following figure shows the error message in the Nymi Band Application.
Figure 1. Enrollment Cannot Proceed
The following errors appear in the nem.log file:
ERROR FAILURE - UpdateBand(api/NymiBands/14): BadRequest - 'Bad Request' - uri:'https://server_name/iis_instance_name/api/NymiBands/14' - headers: '' Response content: {"Message":"{\"ResponseCode\":12,\"Description\":\"Adv Key 1 cannot be generated due to CMAC mismatch.\"}"}
ERROR Failed at Update, api/NymiBands/14
NEM.Server.WebApiException Bad Request
Cause 1
The L2 certificate that Nymi Enterprise Server(NES) uses does not match the L2 certificate that the Nymi Band Application provides to the Nymi Band.
Resolution 1
To resolve this issue:
- Log into NES and perform the following
actions:
- Run NES installer.
- On the Location tab, in the Instance name field, type the IIS instance name, and then click Test. Confirm that the Results box displays Success Update / Re-Install. If you see New Install in the output, ensure that you typed the correct IIS instance name.
- On the Certificates tab, ensure that you select the correct L1 and L2 certificates, and the PFX file that corresponds to the L1 and L2 certificates.
- On the Install tab, click Apply Settings.
- On the enrollment terminal, delete the files in the %APPDATA%\Nymi\NSL folder for the user account that logs into the enrollment terminal.
Cause 2
NES generated an incorrect CMAC.
Resolution 2
Perform one of the following actions:
- Update NES to Connected Worker Platform(CWP) 1.18.0 or later, which contains a fix for this issue.
- Perform a Delete User Data operation on the Nymi Band, and then re-enroll the Nymi Band. If you do not allow self-enrollment,
dissociate the Nymi Band from the user in the
NES Administrator Console before the user attempts the
re-enrollment. Note: If you encounter the issue again, repeat the steps to re-enroll.
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