This error message appears when you attempt to tap to unlock a user terminal with an enrolled Nymi Band or when attempting to perform an SSO action.
Cause 1
- The ManageAccessPoint registry key is not configured correctly on the client.
- The environment uses a centralized Nymi Agent but the Nymi Agent URL definition is incorrect.
Resolution 2
To resolve this issue, perform one of the followings on the Evidian EAM Client and the Evidian EAM Controller:
- Correct the ManageAccessPoint registry key Evidian EAM Client and the Evidian EAM Controller:
- Run regedit.exe.
- Navigate to HKLM\Software\Enatel\Wiseguard\FrameWork\Config\.
- Edit the ManageAccessPoints registry key is set to 1.
- Restart the Enterprise Access Management Security Services service.
- On the client, perform one of the following actions:
- Correct the NymiAgentUrl registry key:
- Run regedit.exe and navigate to HKLM\SOFTWARE\Enatel\WiseGuard\FrameWork\Authentication.
- Ensure that the value in the NymiAgentUrl is correct. The format of the NymiAgentUrl is ws://agent_server_FQDN:9120/socket/websocket
- Correct the nbe.toml file.
- Edit the C:\Nymi\Bluetooth_Enpoint\nbe.toml file.
- Ensure that the agent_url value is correct. The format of the agent_url is agent_url='ws://agent_server_FQDN:9120/socket/websocket'
- Correct the NymiAgentUrl registry key:
Cause 2
The nymi_api.dll file in the Evidian client folder was not replaced with the version of the nymi_api.dll file that is included in the Nymi Runtime software that is installed on the user terminal.
The following error appears in the WGSS log file:
WearableExtension.cpp :0667: <- CWearableExtension::GetKey returned: 0x82002303 AutoLock.cpp :0178: CS Unlock(WEProtectDll) WearableContext.cpp :0486: <- CWearableContext::ConnectUserWearableDevice returned: 0x82002303 CryptoToken_Wearable.cpp :0217: <- CCryptoToken_Wearable::SetAuthenticationData returned: 0x82002303 CryptoToken.cpp :0055: --> CCryptoToken::~CCryptoToken(), this=0xc14ef750 TokenManager_Software.cpp :1481: <- CTokenManager_Software::GetTokenFromAuthenticationToken returned: 0x82002303 FmkSvc_TokenManager.cpp :1394: InternalGetTokenFromAuthenticationToken failed with code=0x82002303
The following error appears in the nymi_api.log file:
sending update to nea {"operation":"get_symmetric_key","exchange":"90","status":2000,"payload":{},"error":{"error_description":"Request made with invalid parameters.","error_specifics":"For key: key_id, Error: Could not decode input to 16 byte array."}}
Resolution 2
- Rename the nymi_api.dll in C:\Program Files\Common Files\Evidian\WGSS.
- From Windows explorer, navigate to Nymi SDK installation package.
- Copy the ..\nymi-sdk\windows\x86_64\nymi_api.dll file to C:\Program Files\Common Files\Evidian\WGSS.
- Log in to the Evidian EAM Management Console.
- Click Account and access rights management
.
-
In the left navigation pane, expand , and then select the terminal, as shown in the following
figure.
- On the Actions tab, select Delete cache files, and then click Apply.The cache files are deleted on the terminal and the terminal desktop locks.
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