Nymi Band Tap Fails Because PAS-X Username is Case Sensitive

When a user launches PAS-X and performs a Nymi Band tap on the Evidian Enterprise SSO log in, the Evidian Enterprise SSO application populates the username in the format that appears in Active Directory(AD). PAS-X requires the username in a particular format, for example in all capital letters, and the tap to complete the authentication does not complete successfully.

Cause

PAS-X usernames are case sensitive and the format of the username that Evidian Enterprise SSO receives from AD is not the format that PAS-X requires.

Resolution

Perform the following step to edit the properties of a window in the Technical Definition to automatically convert the username into the format that PAS-X requires.

  1. From an Evidian EAM Client computer, start Enterprise SSO Studio(ssobuilder.exe), and log in with an EAM administrator account.
  2. Expand Enterprise Studio Configuration > EAM > Evidian Enterprise Access Management > Application access > Technical definitions.
  3. Expand your technical definition, and then right-click on the affected window and select Properties.
  4. On the Actions tab, click Script Editor, as shown in the following figure.
    Figure 1. Script Editor option
  5. On the Custom Script Editor window, select the SendSSO option with the parameter Login to Control.
  6. In the Parameter to Send section that appears, from the String format list, select one of the following options:
    • Convert to lowercase—To populate the value in the Username field in all lowercase letters.
    • Convert to uppercase—To populate the value in the Username field in all uppercase letters.
    • Convert to capitalized—To populate the value in the Username field with first letter capitalization.

      The following figure provides an example of the Custom Script Editor window.

      Figure 2. Custom Script Editor window
    • Click OK.
  7. On the Window Properties window, click OK.
  8. From the Toolbar, click Save changes.

Articles in this section

Was this article helpful?
0 out of 0 found this helpful
Share

Comments

0 comments

Please sign in to leave a comment.